Cable Forum

Cable Forum (https://www.cableforum.uk/board/index.php)
-   Virgin Media Internet Service (https://www.cableforum.uk/board/forumdisplay.php?f=12)
-   -   350M : Latency / Packet Loss to Cloudflare (https://www.cableforum.uk/board/showthread.php?t=33709639)

Synthetic 24-12-2020 21:48

Latency / Packet Loss to Cloudflare
 
Hey,

Just wondering if anyone else has noticed some issues today with latency to cloudflare, seems to be stalling at a core router of virgins again, IP 212.250.14.2

Reply from 212.250.14.2: bytes=32 time=130ms TTL=57
Reply from 212.250.14.2: bytes=32 time=123ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=123ms TTL=57
Reply from 212.250.14.2: bytes=32 time=36ms TTL=57
Reply from 212.250.14.2: bytes=32 time=59ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=112ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=37ms TTL=57
Reply from 212.250.14.2: bytes=32 time=44ms TTL=57
Reply from 212.250.14.2: bytes=32 time=126ms TTL=57
Reply from 212.250.14.2: bytes=32 time=115ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=34ms TTL=57
Reply from 212.250.14.2: bytes=32 time=131ms TTL=57
Reply from 212.250.14.2: bytes=32 time=115ms TTL=57
Reply from 212.250.14.2: bytes=32 time=53ms TTL=57
Reply from 212.250.14.2: bytes=32 time=90ms TTL=57
Reply from 212.250.14.2: bytes=32 time=73ms TTL=57
Request timed out.
Request timed out.
Reply from 212.250.14.2: bytes=32 time=31ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=71ms TTL=57
Reply from 212.250.14.2: bytes=32 time=70ms TTL=57
Reply from 212.250.14.2: bytes=32 time=164ms TTL=57
Reply from 212.250.14.2: bytes=32 time=55ms TTL=57
Reply from 212.250.14.2: bytes=32 time=43ms TTL=57
Reply from 212.250.14.2: bytes=32 time=144ms TTL=57
Reply from 212.250.14.2: bytes=32 time=25ms TTL=57
Reply from 212.250.14.2: bytes=32 time=181ms TTL=57
Reply from 212.250.14.2: bytes=32 time=114ms TTL=57
Reply from 212.250.14.2: bytes=32 time=57ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=45ms TTL=57
Reply from 212.250.14.2: bytes=32 time=116ms TTL=57
Reply from 212.250.14.2: bytes=32 time=102ms TTL=57
Reply from 212.250.14.2: bytes=32 time=88ms TTL=57
Reply from 212.250.14.2: bytes=32 time=67ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=75ms TTL=57
Reply from 212.250.14.2: bytes=32 time=62ms TTL=57

Ping statistics for 212.250.14.2:
Packets: Sent = 65, Received = 56, Lost = 9 (13% loss),
Approximate round trip times in milli-seconds:
Minimum = 25ms, Maximum = 181ms, Average = 83ms

Just wondering if anyone else is seeing the same?

1.1.1.1 seems to be giving similar results

Pinging 1.1.1.1 with 32 bytes of data:
Reply from 1.1.1.1: bytes=32 time=72ms TTL=51
Reply from 1.1.1.1: bytes=32 time=83ms TTL=51
Reply from 1.1.1.1: bytes=32 time=91ms TTL=51
Reply from 1.1.1.1: bytes=32 time=36ms TTL=51
Reply from 1.1.1.1: bytes=32 time=114ms TTL=51
Reply from 1.1.1.1: bytes=32 time=37ms TTL=51
Reply from 1.1.1.1: bytes=32 time=139ms TTL=51
Reply from 1.1.1.1: bytes=32 time=46ms TTL=51
Reply from 1.1.1.1: bytes=32 time=139ms TTL=51
Reply from 1.1.1.1: bytes=32 time=145ms TTL=51
Reply from 1.1.1.1: bytes=32 time=45ms TTL=51
Reply from 1.1.1.1: bytes=32 time=55ms TTL=51
Reply from 1.1.1.1: bytes=32 time=61ms TTL=51
Reply from 1.1.1.1: bytes=32 time=74ms TTL=51

Ping statistics for 1.1.1.1:
Packets: Sent = 14, Received = 14, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 145ms, Average = 81ms



Cheers!

General Maximus 24-12-2020 23:34

Re: Latency / Packet Loss to Cloudflare
 
Pinging 1.1.1.1 with 32 bytes of data:
Reply from 1.1.1.1: bytes=32 time=20ms TTL=50
Reply from 1.1.1.1: bytes=32 time=21ms TTL=50
Reply from 1.1.1.1: bytes=32 time=17ms TTL=50
Reply from 1.1.1.1: bytes=32 time=17ms TTL=50
Reply from 1.1.1.1: bytes=32 time=18ms TTL=50
Reply from 1.1.1.1: bytes=32 time=18ms TTL=50
Reply from 1.1.1.1: bytes=32 time=16ms TTL=50
Reply from 1.1.1.1: bytes=32 time=19ms TTL=50
Reply from 1.1.1.1: bytes=32 time=17ms TTL=50
Reply from 1.1.1.1: bytes=32 time=17ms TTL=50

Ping statistics for 1.1.1.1:
Packets: Sent = 10, Received = 10, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 21ms, Average = 18ms




Pinging 212.250.14.2 with 32 bytes of data:
Reply from 212.250.14.2: bytes=32 time=28ms TTL=57
Reply from 212.250.14.2: bytes=32 time=24ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Reply from 212.250.14.2: bytes=32 time=23ms TTL=57
Reply from 212.250.14.2: bytes=32 time=19ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=24ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Request timed out.
Reply from 212.250.14.2: bytes=32 time=26ms TTL=57
Reply from 212.250.14.2: bytes=32 time=26ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=28ms TTL=57
Reply from 212.250.14.2: bytes=32 time=19ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=22ms TTL=57
Reply from 212.250.14.2: bytes=32 time=22ms TTL=57
Reply from 212.250.14.2: bytes=32 time=19ms TTL=57
Reply from 212.250.14.2: bytes=32 time=25ms TTL=57
Reply from 212.250.14.2: bytes=32 time=38ms TTL=57
Reply from 212.250.14.2: bytes=32 time=24ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57
Reply from 212.250.14.2: bytes=32 time=25ms TTL=57
Reply from 212.250.14.2: bytes=32 time=29ms TTL=57
Reply from 212.250.14.2: bytes=32 time=19ms TTL=57
Reply from 212.250.14.2: bytes=32 time=18ms TTL=57
Reply from 212.250.14.2: bytes=32 time=28ms TTL=57
Reply from 212.250.14.2: bytes=32 time=23ms TTL=57
Reply from 212.250.14.2: bytes=32 time=27ms TTL=57
Reply from 212.250.14.2: bytes=32 time=22ms TTL=57
Reply from 212.250.14.2: bytes=32 time=22ms TTL=57
Reply from 212.250.14.2: bytes=32 time=21ms TTL=57
Reply from 212.250.14.2: bytes=32 time=31ms TTL=57
Reply from 212.250.14.2: bytes=32 time=23ms TTL=57
Reply from 212.250.14.2: bytes=32 time=24ms TTL=57
Reply from 212.250.14.2: bytes=32 time=20ms TTL=57

Ping statistics for 212.250.14.2:
Packets: Sent = 43, Received = 42, Lost = 1 (2% loss),
Approximate round trip times in milli-seconds:
Minimum = 18ms, Maximum = 38ms, Average = 22ms

Martin_D 24-12-2020 23:58

Re: Latency / Packet Loss to Cloudflare
 
Ok on BT

PING 212.250.14.2 (212.250.14.2): 56 data bytes
64 bytes from 212.250.14.2: seq=0 ttl=59 time=18.711 ms
64 bytes from 212.250.14.2: seq=1 ttl=59 time=21.519 ms
64 bytes from 212.250.14.2: seq=2 ttl=59 time=18.700 ms
64 bytes from 212.250.14.2: seq=3 ttl=59 time=18.772 ms
64 bytes from 212.250.14.2: seq=4 ttl=59 time=18.671 ms
64 bytes from 212.250.14.2: seq=5 ttl=59 time=19.243 ms
64 bytes from 212.250.14.2: seq=6 ttl=59 time=18.927 ms
64 bytes from 212.250.14.2: seq=7 ttl=59 time=19.687 ms
64 bytes from 212.250.14.2: seq=8 ttl=59 time=19.387 ms
64 bytes from 212.250.14.2: seq=9 ttl=59 time=45.499 ms
64 bytes from 212.250.14.2: seq=10 ttl=59 time=20.864 ms
64 bytes from 212.250.14.2: seq=11 ttl=59 time=22.014 ms
64 bytes from 212.250.14.2: seq=12 ttl=59 time=26.704 ms
64 bytes from 212.250.14.2: seq=13 ttl=59 time=22.866 ms
64 bytes from 212.250.14.2: seq=14 ttl=59 time=26.236 ms

--- 212.250.14.2 ping statistics ---
15 packets transmitted, 15 packets received, 0% packet loss
round-trip min/avg/max = 18.671/22.520/45.499 ms

PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=58 time=13.554 ms
64 bytes from 1.1.1.1: seq=1 ttl=58 time=13.300 ms
64 bytes from 1.1.1.1: seq=2 ttl=58 time=12.930 ms
64 bytes from 1.1.1.1: seq=3 ttl=58 time=12.965 ms
64 bytes from 1.1.1.1: seq=4 ttl=58 time=13.388 ms
64 bytes from 1.1.1.1: seq=5 ttl=58 time=13.104 ms
64 bytes from 1.1.1.1: seq=6 ttl=58 time=13.038 ms
64 bytes from 1.1.1.1: seq=7 ttl=58 time=13.470 ms
64 bytes from 1.1.1.1: seq=8 ttl=58 time=14.407 ms
64 bytes from 1.1.1.1: seq=9 ttl=58 time=13.428 ms
64 bytes from 1.1.1.1: seq=10 ttl=58 time=13.060 ms
64 bytes from 1.1.1.1: seq=11 ttl=58 time=13.091 ms
64 bytes from 1.1.1.1: seq=12 ttl=58 time=13.405 ms
64 bytes from 1.1.1.1: seq=13 ttl=58 time=13.019 ms
64 bytes from 1.1.1.1: seq=14 ttl=58 time=13.465 ms

--- 1.1.1.1 ping statistics ---
15 packets transmitted, 15 packets received, 0% packet loss
round-trip min/avg/max = 12.930/13.308/14.407 ms

Synthetic 25-12-2020 08:42

Re: Latency / Packet Loss to Cloudflare
 
Thanks guys, looks like it might be a local thing then

alanbjames 26-12-2020 03:30

Re: Latency / Packet Loss to Cloudflare
 
C:\WINDOWS\system32>ping 212.250.14.2

Pinging 212.250.14.2 with 32 bytes of data:
Reply from 212.250.14.2: bytes=32 time=17ms TTL=59
Reply from 212.250.14.2: bytes=32 time=17ms TTL=59
Reply from 212.250.14.2: bytes=32 time=15ms TTL=59
Reply from 212.250.14.2: bytes=32 time=15ms TTL=59

Ping statistics for 212.250.14.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 15ms, Maximum = 17ms, Average = 16ms

C:\WINDOWS\system32>ping 1.1.1.1

Pinging 1.1.1.1 with 32 bytes of data:
Reply from 1.1.1.1: bytes=32 time=18ms TTL=58
Reply from 1.1.1.1: bytes=32 time=18ms TTL=58
Reply from 1.1.1.1: bytes=32 time=13ms TTL=58
Reply from 1.1.1.1: bytes=32 time=13ms TTL=58

Ping statistics for 1.1.1.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 18ms, Average = 15ms

Mine works fine as u can see.

fizzyade 28-12-2020 01:25

Re: Latency / Packet Loss to Cloudflare
 
I was seeing a lot of packet loss to 1.1.1.1 earlier on this evening, but it seems to have gone away now.
https://www.cableforum.uk/images/local/2020/12/9.png

rtho782 28-12-2020 11:38

Re: Latency / Packet Loss to Cloudflare
 
Aggregate stats from 4 VM users here, all showing packetloss to 1.1.1.1 and 212.250.14.2 this morning indicating cloudflare issues again.

2 of the users are on RFoG, 2 on HFC, across the country (southwest, london, east anglia)

https://www.cableforum.uk/images/local/2020/12/10.png

fizzyade 28-12-2020 14:13

Re: Latency / Packet Loss to Cloudflare
 
I'm back with packet loss, trying to do anything on the web is painful, timeouts because of DNS problems.

I'm temporarily switching DNS to 8.8.8.8 until this problem with cloudflare (again!) is cleared up.

rtho782 28-12-2020 14:39

Re: Latency / Packet Loss to Cloudflare
 
The issue doesn't seem to actually be with cloudflare, given the losses to 212.250.14.2 (which is inside VM's network). It's an internal VM network issue that impacts cloudflare.

fizzyade 28-12-2020 16:48

Re: Latency / Packet Loss to Cloudflare
 
Quote:

Originally Posted by rtho782 (Post 36063979)
The issue doesn't seem to actually be with cloudflare, given the losses to 212.250.14.2 (which is inside VM's network). It's an internal VM network issue that impacts cloudflare.

That's a red herring, that node is either rate limiting ICMP, blocking them as it thinks there's a DDOS or just treating ICMP packets as low priority, you can see there's a bump in latency to that node before it drops down to the final node.

I've left it capturing for last hour or so and here's the last few minutes of data.

https://www.cableforum.uk/images/local/2020/12/11.png

Synthetic 28-12-2020 18:57

Re: Latency / Packet Loss to Cloudflare
 
Glad to see it's not just me, but slightly frustrating the same issue has returned

rtho782 28-12-2020 18:57

Re: Latency / Packet Loss to Cloudflare
 
Quote:

Originally Posted by fizzyade (Post 36063994)
That's a red herring, that node is either rate limiting ICMP, blocking them as it thinks there's a DDOS or just treating ICMP packets as low priority, you can see there's a bump in latency to that node before it drops down to the final node.

I've left it capturing for last hour or so and here's the last few minutes of data.

You say that, but I have been running monitoring for weeks and the packet loss to the VM IP is only when there is also packet loss to Cloudflare.

So maybe that gateway is just running hot or something, but either way the issue seems to be VM's to me.

Synthetic 28-12-2020 19:26

Re: Latency / Packet Loss to Cloudflare
 
Quote:

Originally Posted by rtho782 (Post 36064007)
You say that, but I have been running monitoring for weeks and the packet loss to the VM IP is only when there is also packet loss to Cloudflare.

So maybe that gateway is just running hot or something, but either way the issue seems to be VM's to me.

Seems to be VM's last hop before handing off to cloudflare, wonder if Virgin have all their cloudflare peering running through a single endpoint...

fizzyade 28-12-2020 21:27

Re: Latency / Packet Loss to Cloudflare
 
Quote:

Originally Posted by rtho782 (Post 36064007)
You say that, but I have been running monitoring for weeks and the packet loss to the VM IP is only when there is also packet loss to Cloudflare.

So maybe that gateway is just running hot or something, but either way the issue seems to be VM's to me.

Yeah, sorry I wasn't clear, what I meant was don't take too much stock from that hop because it always looks funny. The issue last time (a few weeks back) was a VM fault so it's most likely it is them.

Also if you run back to back traceroutes to a destination with a 1s delay you'll quickly see that Hop 2 starts dropping ICMP packets.

fizzyade 29-12-2020 00:41

Re: Latency / Packet Loss to Cloudflare
 
It's been wonky all evening, browsing the web was a miserable experience of page timeouts.

Suddenly though, all packet loss has stopped. The same thing happened last night.


All times are GMT +1. The time now is 21:56.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.